nixdots/home/programs/terminal/tools/git/gh.nix
2024-07-27 01:07:07 +02:00

17 lines
417 B
Nix

{pkgs, ...}: {
programs.gh = {
enable = true;
gitCredentialHelper.enable = false;
extensions = with pkgs; [
gh-dash # dashboard with pull requess and issues
gh-eco # explore the ecosystem
gh-cal # contributions calendar terminal viewer
gh-notify # access and manage github notifications
];
settings = {
git_protocol = "ssh";
prompt = "enabled";
};
};
}