nixdots/options/home/services.nix
2024-08-08 12:17:05 +02:00

18 lines
533 B
Nix

{lib, ...}:
with lib; let
inherit (lib) mkEnableOption mkOption types;
in {
options.myOptions.home-manager.services = {
dunst.enable = mkEnableOption "Dunst (lightweight notification daemon)";
hyprpaper = {
enable = mkEnableOption "Hyprpaper (Hyprland wallpaper daemon)";
wallpaperPath = mkOption {
type = types.path;
default = null;
description = "Path to the wallpaper of your choosing";
};
};
hypridle.enable = mkEnableOption "Hypridle (Hyprland idle daemon)";
};
}