mirror of
https://github.com/ItsDrike/nixdots
synced 2024-11-10 02:19:41 +00:00
ItsDrike
00016063fe
Originally, I was including all role configurations for all hosts, and controlling which get applied in the role configs with a check in each file. This is a very repetetive and annoying approach. Instead, now the role directory is included manually from the hosts config for devices which meet that role, removing the role options.
21 lines
327 B
Nix
21 lines
327 B
Nix
{
|
|
pkgs,
|
|
config,
|
|
...
|
|
}: {
|
|
hardware.acpilight.enable = true;
|
|
|
|
environment.systemPackages = with pkgs; [acpi];
|
|
|
|
# handle ACPI events
|
|
services.acpid.enable = true;
|
|
|
|
boot = {
|
|
kernelModules = ["acpi_call"];
|
|
extraModulePackages = with config.boot.kernelPackages; [
|
|
acpi_call
|
|
cpupower
|
|
];
|
|
};
|
|
}
|