mirror of
https://github.com/ItsDrike/nixdots
synced 2024-11-13 00:47:19 +00:00
ItsDrike
00016063fe
Originally, I was including all role configurations for all hosts, and controlling which get applied in the role configs with a check in each file. This is a very repetetive and annoying approach. Instead, now the role directory is included manually from the hosts config for devices which meet that role, removing the role options.
26 lines
401 B
Nix
26 lines
401 B
Nix
{
|
|
# unlock GPG keyring on login
|
|
security.pam.services = let
|
|
gnupg = {
|
|
enable = true;
|
|
noAutostart = true;
|
|
storeOnly = true;
|
|
};
|
|
in {
|
|
login = {
|
|
enableGnomeKeyring = true;
|
|
inherit gnupg;
|
|
};
|
|
|
|
greetd = {
|
|
enableGnomeKeyring = true;
|
|
inherit gnupg;
|
|
};
|
|
|
|
tuigreet = {
|
|
enableGnomeKeyring = true;
|
|
inherit gnupg;
|
|
};
|
|
};
|
|
}
|