mirror of
https://github.com/ItsDrike/nixdots
synced 2024-11-10 02:49:41 +00:00
ItsDrike
00016063fe
Originally, I was including all role configurations for all hosts, and controlling which get applied in the role configs with a check in each file. This is a very repetetive and annoying approach. Instead, now the role directory is included manually from the hosts config for devices which meet that role, removing the role options.
18 lines
609 B
Nix
18 lines
609 B
Nix
{
|
|
# Screen locker which works across all virtual terminals
|
|
# Use `systemctl start physlock` to securely lock the screen
|
|
services.physlock = {
|
|
enable = true;
|
|
lockMessage = "System is locked...";
|
|
|
|
# I only use physlock manually in some circumstances
|
|
lockOn = {
|
|
# Don't auto-lock the system with physlock on suspend, I prefer other (gui) lockers
|
|
suspend = false;
|
|
# Do use physlock on resuming from hibernation though, as this just restored RAM,
|
|
# potentially bypassing the login screen and even initial disk encryption password
|
|
hibernate = true;
|
|
};
|
|
};
|
|
}
|