mirror of
https://github.com/ItsDrike/nixdots
synced 2024-11-10 02:19:41 +00:00
ItsDrike
00016063fe
Originally, I was including all role configurations for all hosts, and controlling which get applied in the role configs with a check in each file. This is a very repetetive and annoying approach. Instead, now the role directory is included manually from the hosts config for devices which meet that role, removing the role options.
26 lines
591 B
Nix
26 lines
591 B
Nix
{pkgs, ...}: {
|
|
# Unconditionally enable thunar file manager here as a relatively
|
|
# lightweight fallback option for my default file manager.
|
|
programs.thunar = {
|
|
enable = true;
|
|
|
|
plugins = with pkgs.xfce; [
|
|
thunar-archive-plugin
|
|
thunar-media-tags-plugin
|
|
];
|
|
};
|
|
|
|
environment = {
|
|
systemPackages = with pkgs; [
|
|
# packages necessery for thunar thumbnails
|
|
xfce.tumbler
|
|
libgsf # odf files
|
|
ffmpegthumbnailer
|
|
ark # GUI archiver for thunar archive plugin
|
|
];
|
|
};
|
|
|
|
# thumbnail support on thunar
|
|
services.tumbler.enable = true;
|
|
}
|