nixdots/system/roles/workstation/programs/virtualbox.nix
ItsDrike 00016063fe
Use roles properly
Originally, I was including all role configurations for all hosts, and
controlling which get applied in the role configs with a check in each
file. This is a very repetetive and annoying approach. Instead, now the
role directory is included manually from the hosts config for devices
which meet that role, removing the role options.
2024-09-24 11:42:40 +02:00

22 lines
494 B
Nix

{
lib,
config,
...
}: let
inherit (lib) mkIf;
cfgUser = config.myOptions.system.username;
cfg = config.myOptions.home-manager.programs.applications.virtualbox;
in {
config = mkIf cfg.enable {
virtualisation.virtualbox.host = {
enable = true;
# Don't include the Qt dependency and GUI app,
# if gui is desired, it can be installed separately on a per-user basis
headless = true;
};
users.extraGroups.vboxusers.members = ["${cfgUser}"];
};
}