nixdots/system/roles/workstation/programs/wireshark.nix
ItsDrike 00016063fe
Use roles properly
Originally, I was including all role configurations for all hosts, and
controlling which get applied in the role configs with a check in each
file. This is a very repetetive and annoying approach. Instead, now the
role directory is included manually from the hosts config for devices
which meet that role, removing the role options.
2024-09-24 11:42:40 +02:00

20 lines
366 B
Nix

{
lib,
pkgs,
config,
...
}: let
inherit (lib) mkIf;
cfgUser = config.myOptions.system.username;
cfg = config.myOptions.home-manager.programs.applications.wireshark;
in {
config = mkIf cfg.enable {
programs.wireshark = {
enable = true;
package = pkgs.wireshark;
};
users.extraGroups.wireshark.members = ["${cfgUser}"];
};
}