mirror of
https://github.com/ItsDrike/nixdots
synced 2024-11-10 02:49:41 +00:00
ItsDrike
00016063fe
Originally, I was including all role configurations for all hosts, and controlling which get applied in the role configs with a check in each file. This is a very repetetive and annoying approach. Instead, now the role directory is included manually from the hosts config for devices which meet that role, removing the role options.
20 lines
366 B
Nix
20 lines
366 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
config,
|
|
...
|
|
}: let
|
|
inherit (lib) mkIf;
|
|
cfgUser = config.myOptions.system.username;
|
|
cfg = config.myOptions.home-manager.programs.applications.wireshark;
|
|
in {
|
|
config = mkIf cfg.enable {
|
|
programs.wireshark = {
|
|
enable = true;
|
|
package = pkgs.wireshark;
|
|
};
|
|
|
|
users.extraGroups.wireshark.members = ["${cfgUser}"];
|
|
};
|
|
}
|