nixdots/system/shared/services/docker.nix
2024-08-24 10:48:05 +02:00

17 lines
256 B
Nix

{
lib,
config,
...
}: let
cfg = config.myOptions.system.docker;
in {
config = lib.mkIf cfg.enable {
virtualisation.docker = {
enable = true;
storageDriver = "btrfs";
daemon.settings.data-root = cfg.data-root;
};
};
}